二维树状数组入门题

Matrix (poj 2155)

传送门

Time Limit: 3000MS

Memory Limit: 65536K

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y]. Input
    The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
Source
POJ Monthly,Lou Tiancheng

题意

对于一个0,1矩阵,支持左下(x1,y1)-右上(x2,y2)矩形区域内的反转,然后对单点(x,y)的查询。

Solution

今天才学的二维树状数组(菜的一匹),其实看到对于一个二维区域的维护应该就能想到这类型的数据结构。那么对于单点查询,结合树状数组可想到是由差分来实现的,因为树状数组只能提取前缀和。然后对于一个二维平面如何加值,类似于一维中的s[x]+v,s[y]-v。推广到二维则有:

image

可以看一下这个图。
image

另外题面中的加大的字各位可以品尝..QAQ

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int s[2100][2100],n,q;
int lowbit(int x){return x&(-x);}
void add(int x,int y,int c)
{
for(int i=x;i<=n;i+=lowbit(i))
for(int j=y;j<=n;j+=lowbit(j))
s[i][j]+=c;
}
int query(int x,int y)
{
int rtn=0;
for(int i=x;i;i-=lowbit(i))
for(int j=y;j;j-=lowbit(j))
rtn+=s[i][j];
return rtn;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&q);
memset(s,0,sizeof(s));
while(q--)
{
char ch[5];
scanf("%s",ch);
if(ch[0]=='C')
{
int x1,y1,x2,y2;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
add(x2+1,y2+1,1);
add(x1,y2+1,-1);
add(x2+1,y1,-1);
add(x1,y1,1);
}
if(ch[0]=='Q')
{
int x,y;
scanf("%d%d",&x,&y);
printf("%d\n",query(x,y)%2);
}
}
printf("\n");
}
return 0;
}
/*
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
*/

×

纯属好玩

扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦

文章目录
  1. 1. Matrix (poj 2155)
  2. 2. 传送门
    1. 2.0.1. Time Limit: 3000MS
    2. 2.0.2. Memory Limit: 65536K
  3. 2.1. Description
  • 3. There is a blank line between every two continuous test cases.
    1. 3.0.1. Sample Input
    2. 3.0.2. Sample Output
  • 3.1. 题意
  • 4. Solution
  • ,